const regex = /<iframe[\S\s]*?src=".*?\.(\w+)\..*?"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<iframe[\\S\\s]*?src=".*?\\.(\\w+)\\..*?"', 'g')
const str = `<iframe id="ytplayer" type="text/html" width="640" height="360"
src="http://www.youtube.com/embed/M7lc1UVf-VE?autoplay=1&origin=http://example.com"
frameborder="0"/>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}