#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mx)"[^"]+"(*SKIP)(*FAIL)" & @CRLF & _
"|" & @CRLF & _
"\(" & @CRLF & _
" (?:[^()]*|(?R))+" & @CRLF & _
"\)"
Local $sString = ""Hello World (Don't want to strip this (also not this))" anything outside round brackets should remain as is(strip this (strip this also as it is outside double quotes))" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)