using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^""]+""(*SKIP)(*FAIL)
|
\(
(?:[^()]*|(?R))+
\)";
string substitution = @"";
string input = @"""Hello World (Don't want to strip this (also not this))"" anything outside round brackets should remain as is(strip this (strip this also as it is outside double quotes))
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}