use strict;
my $str = '"Hello World (Don\'t want to strip this (also not this))" anything outside round brackets should remain as is(strip this (strip this also as it is outside double quotes))
';
my $regex = qr~"[^"]+"(*SKIP)(*FAIL)
|
\(
(?:[^()]*|(?R))+
\)~mxp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";