// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mx)"[^"]+"(*SKIP)(*FAIL)
|
\(
(?:[^()]*|(?R))+
\)"#).unwrap();
let string = "\"Hello World (Don't want to strip this (also not this))\" anything outside round brackets should remain as is(strip this (strip this also as it is outside double quotes))
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}