#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)([a-z])\1{3,}"
Local $sString = "a" & @CRLF & _
"ab" & @CRLF & _
"abc" & @CRLF & _
"1" & @CRLF & _
"22" & @CRLF & _
"22AB" & @CRLF & _
"AB" & @CRLF & _
"ABC" & @CRLF & _
"ABBC" & @CRLF & _
"ABBCCDD" & @CRLF & _
"EFAEEEEEEE" & @CRLF & _
"EEE" & @CRLF & _
"EE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")