$re = '/([a-z])\1{3,}/im';
$str = 'a
ab
abc
1
22
22AB
AB
ABC
ABBC
ABBCCDD
EFAEEEEEEE
EEE
EE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);