# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(href=")([^"]*\.[^".]+)(")/$1\L$2\E$3/gm;t' <<< "<li><a href=\"Blah/Index.html\">Blah</a></li>
<li><a href=\"/blah/Index.html\">Blah</a></li>
<li><a href=\"../Blah/index.html\">Blah</a></li>
<li><a href=\"../Foo/Index.html\">Foo</a></li>"