#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ":[^%]\D\w*"
Local $sString = "SELECT cID, cTIME, DATE_FORMAT(cDATUM,'%d.%m.%Y %H:%i') as cDATA FROM tMyTable WHERE cTIME = '0000-00-00 00:00:00' and cID > :param1;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")