using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":[^%]\D\w*";
string input = @"SELECT cID, cTIME, DATE_FORMAT(cDATUM,'%d.%m.%Y %H:%i') as cDATA FROM tMyTable WHERE cTIME = '0000-00-00 00:00:00' and cID > :param1;";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}