package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`:[^%]\D\w*`)
var str = `SELECT cID, cTIME, DATE_FORMAT(cDATUM,'%d.%m.%Y %H:%i') as cDATA FROM tMyTable WHERE cTIME = '0000-00-00 00:00:00' and cID > :param1;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}