use strict;
my $str = 'SELECT cID, cTIME, DATE_FORMAT(cDATUM,\'%d.%m.%Y %H:%i\') as cDATA FROM tMyTable WHERE cTIME = \'0000-00-00 00:00:00\' and cID > :param1;';
my $regex = qr/:[^%]\D\w*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}