import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<tr class=\"class1\">)([\\s\\S]*?)(<\\/tr>)";
final String string = "<tr class=\"class1\">\n"
+ " <td class=\"class2\">\n"
+ " <a href=\"some_address\"></a>\n"
+ " <div id=\"id1\">\n"
+ " <span class=\"class3\"></span>\n"
+ " </div>\n"
+ " <span>Just a text</span>\n"
+ " </td>\n"
+ "</tr>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}