const regex = /(<tr class="class1">)([\s\S]*?)(<\/tr>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<tr class="class1">)([\\s\\S]*?)(<\\\/tr>)', 'gm')
const str = `<tr class="class1">
<td class="class2">
<a href="some_address"></a>
<div id="id1">
<span class="class3"></span>
</div>
<span>Just a text</span>
</td>
</tr>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}