import re
regex = re.compile(r"(<tr class=\"class1\">)([\s\S]*?)(<\/tr>)", flags=re.MULTILINE)
test_str = ("<tr class=\"class1\">\n"
" <td class=\"class2\">\n"
" <a href=\"some_address\"></a>\n"
" <div id=\"id1\">\n"
" <span class=\"class3\"></span>\n"
" </div>\n"
" <span>Just a text</span>\n"
" </td>\n"
"</tr>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")