re = /(<tr class="class1">)([\s\S]*?)(<\/tr>)/m
str = '<tr class="class1">
<td class="class2">
<a href="some_address"></a>
<div id="id1">
<span class="class3"></span>
</div>
<span>Just a text</span>
</td>
</tr>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end