// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(<tr class="class1">)([\s\S]*?)(<\/tr>)"#).unwrap();
let string = "<tr class=\"class1\">
<td class=\"class2\">
<a href=\"some_address\"></a>
<div id=\"id1\">
<span class=\"class3\"></span>
</div>
<span>Just a text</span>
</td>
</tr>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}