using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^=\r\n]+)=([^#\r\n]+)";
string input = @"foo = ""/usr/local/bin"" # path string
eggs = [0, 1, 2, 3, 1]
spam = True # boolean
bar = 42";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}