re = /^(\s*)?(\+)?([- _():=+]?\d[- _():=+]?){10,14}(\s*)?$/m
str = '+79126819285'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end