package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`is`)
var str = `Is this all there is?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}