#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^thieme-\d{2}-jats_\S*_\d{4}_\S*"
Local $sString = "thieme-19-jats_10.1055-s-00000011_2023_12_20230531/1928-0362/10-1055-a-1870-4243.xml"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")