re = /^thieme-\d{2}-jats_\S*_\d{4}_\S*/
str = 'thieme-19-jats_10.1055-s-00000011_2023_12_20230531/1928-0362/10-1055-a-1870-4243.xml'
# Print the match result
str.match(re) do |match|
puts match.to_s
end