use strict;
my $str = 'PENNER,JANET E TR-50% & PENNER,MICHAEL G TR - 50% & SOURCE LLC & LARRY & FREDDY INC';
my $regex = qr/(?:^|&) *(.*?(?:TR|LLC|INC)).*?(?=&|$)/mp;
my $subst = '- $1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";