import Foundation
let pattern = #"(.+$)\RAnzahl:\h(\d+)\R?(?:\h+davon\R(?:\h+(\d+)\h(.+$)\R?))?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Installierte Busteilnehmer
Anzahl: 1723
automatische Melder
Anzahl: 1490 davon
43 Thermodiff. Melder
1447 O2T-Melder
nicht automatische Melder
Anzahl: 144
Koppler
Anzahl: 45 davon
15 Funkkoppler (81 Funksockel)
Signalgeber
Anzahl: 857 davon
8 Sprachalarmierung
793 Sprachalarmierung integriert im Melder
36 optisch/Sprache
20 optisch/Sprache integriert im Melder
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)