using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^test(?:\/\d+)+$";
string input = @"test/1/5
test/1/2/5
test/1/2/3/5
test/1/2/3/4/5
test/1,2/5
test/1/2/5aaa";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}