$re = '/(?s)^.*password=.*/';
$str = 'line1
line2
password=line3
line4';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);