using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img\s+src.+^(?!alt).+";
string input = @"<img src=""smiley.gif"" alt=""Smiley face"" height=""42"" width=""42"">
<img src=""smiley2.gif"" height=""42"" width=""42"">
<img src=""smiley3.gif"" alt=""Smiley face Three"" height=""42"" width=""42"">";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}