import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img\\s+src.+^(?!alt).+";
final String string = "<img src=\"smiley.gif\" alt=\"Smiley face\" height=\"42\" width=\"42\">\n"
+ "<img src=\"smiley2.gif\" height=\"42\" width=\"42\">\n"
+ "<img src=\"smiley3.gif\" alt=\"Smiley face Three\" height=\"42\" width=\"42\">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}