// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*PN: (.+)BN:\s*([0-9]{7}).*").unwrap();
let string = "colder.com/AQGdataPN: AQG17006HTBN: 85065002023/06/22
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}