package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^50|^49)\d{8}`)
var str = `4923456321
7725738388
5012345678`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}