use strict;
my $str = 'TEST:ABCDEGF:18:32:aa:12';
my $regex = qr/(\d\d\:\d\d)|\:/mp;
my $subst = '$1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";