#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*(.*)\s*Disk.*"
Local $sString = " Sharename Type Comment" & @CRLF & _
" --------- ---- -------" & @CRLF & _
" ADMIN$ Disk Remote Admin" & @CRLF & _
" C$ Disk Default share" & @CRLF & _
" CertEnroll Disk Active Directory Certificate Services share" & @CRLF & _
" Department Shares Disk " & @CRLF & _
" IPC$ IPC Remote IPC" & @CRLF & _
" NETLOGON Disk Logon server share " & @CRLF & _
" Operations Disk " & @CRLF & _
" SYSVOL Disk Logon server share " & @CRLF & _
"Reconnecting with SMB1 for workgroup listing." & @CRLF & _
"Connection to 10.10.10.103 failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)" & @CRLF & _
"Failed to connect with SMB1 -- no workgroup available" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")