const regex = /^\s*(.*)\s*Disk.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(.*)\\s*Disk.*', 'gm')
const str = ` Sharename Type Comment
--------- ---- -------
ADMIN\$ Disk Remote Admin
C\$ Disk Default share
CertEnroll Disk Active Directory Certificate Services share
Department Shares Disk
IPC\$ IPC Remote IPC
NETLOGON Disk Logon server share
Operations Disk
SYSVOL Disk Logon server share
Reconnecting with SMB1 for workgroup listing.
Connection to 10.10.10.103 failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
Failed to connect with SMB1 -- no workgroup available
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}