# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*(.*)\s*Disk.*"
test_str = (" Sharename Type Comment\n"
" --------- ---- -------\n"
" ADMIN$ Disk Remote Admin\n"
" C$ Disk Default share\n"
" CertEnroll Disk Active Directory Certificate Services share\n"
" Department Shares Disk \n"
" IPC$ IPC Remote IPC\n"
" NETLOGON Disk Logon server share \n"
" Operations Disk \n"
" SYSVOL Disk Logon server share \n"
"Reconnecting with SMB1 for workgroup listing.\n"
"Connection to 10.10.10.103 failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)\n"
"Failed to connect with SMB1 -- no workgroup available\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.