// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)iOS[89]|iOS[1][0-3]").unwrap();
let string = "iOS7
iOS8
iOS9
iOS10
iOS11
iOS12
iOS13
iOS14";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}