#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<![^\W_])int(?![^\W_])"
Local $sString = "int # match" & @CRLF & _
"_int_ # match" & @CRLF & _
"__int__ # match" & @CRLF & _
"some_int # match" & @CRLF & _
"integration # doesn't match" & @CRLF & _
"mint # doesn't match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")