const regex = /\b(?:[ptkmnlswj]?
(?:(?<=w)[aei]|
(?<=[jt])[aeou]|
(?<=[pkmnls])[aeiou]|
(?<=\b)[aeiou])
(?:n(?![nm]?[aeiou]))?)+\b/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:[ptkmnlswj]?
(?:(?<=w)[aei]|
(?<=[jt])[aeou]|
(?<=[pkmnls])[aeiou]|
(?<=\\b)[aeiou])
(?:n(?![nm]?[aeiou]))?)+\\b', 'ig')
const str = `panna
jijin
titin
wowu
wonwun
tewun
tetin
tejin
teji
aan
---
mama
seme
pona
toki pona li toki suwi
jan Lili li lili
ni li ilo Lekula Epesen. ni li ken lanpan e nimi mute
eni
nanma
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}