#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s).*\K2. \]|.*\K3. \]|.*\K4. \]|.*\K5. \]|.*\K6. \]|.*\K7. \]"
Local $sString = "|dart24356- shows [ 8d 9h ]|" & @CRLF & _
"" & @CRLF & _
"|dart24356- shows [ 8d 5h ]|" & @CRLF & _
"" & @CRLF & _
"|dart24356- shows [ Kd Kh ]|" & @CRLF & _
"" & @CRLF & _
"|dart24356- shows [ Qc Ac ] |" & @CRLF & _
"" & @CRLF & _
"|dart24356- shows [ 2d 4h ]|" & @CRLF & _
"" & @CRLF & _
"|dart24356- shows [ 3d 3h ]|" & @CRLF & _
"" & @CRLF & _
"|dart24356- shows [ Kd Kh ]|" & @CRLF & _
"" & @CRLF & _
"|dart24356- shows [ 8d 5h ]|" & @CRLF & _
"" & @CRLF & _
"|dart24356- shows [ Qc Ac ] |"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")