# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*\K2. \]|.*\K3. \]|.*\K4. \]|.*\K5. \]|.*\K6. \]|.*\K7. \]"
test_str = ("|dart24356- shows [ 8d 9h ]|\n\n"
"|dart24356- shows [ 8d 5h ]|\n\n"
"|dart24356- shows [ Kd Kh ]|\n\n"
"|dart24356- shows [ Qc Ac ] |\n\n"
"|dart24356- shows [ 2d 4h ]|\n\n"
"|dart24356- shows [ 3d 3h ]|\n\n"
"|dart24356- shows [ Kd Kh ]|\n\n"
"|dart24356- shows [ 8d 5h ]|\n\n"
"|dart24356- shows [ Qc Ac ] |")
matches = re.search(regex, test_str, re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.