package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[json]:#.\(([^*]*)\)`)
var str = `[json]:# (
[
{"jira": "proj-4753"},
{"creation": "2021-09-25"}
]
)
# Title
## 1. Conclusion
Jada, jada
## 2. Recomendation
blah, blah
[json]:# (
[
{"sensitivity": "internal"}
]
)
More data
[json]:# (
[
{"uid": "abc002334"}
]
)
and this`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}