package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)NAME="var1".+?VALUE="(.+?)"`)
var str = `<INPUT TYPE="HIDDEN" NAME="var1" VALUE="value that i want to be captured"/><INPUT TYPE="HIDDEN" NAME="var2" VALUE="value2"/><INPUT TYPE="SUBMIT" VALUE="value that is captured, but i don't want to be captured" />`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}