use strict;
my $str = '<INPUT TYPE="HIDDEN" NAME="var1" VALUE="value that i want to be captured"/><INPUT TYPE="HIDDEN" NAME="var2" VALUE="value2"/><INPUT TYPE="SUBMIT" VALUE="value that is captured, but i don\'t want to be captured" />';
my $regex = qr/NAME="var1".+?VALUE="(.+?)"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}