// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)NAME="var1".+?VALUE="(.+?)""#).unwrap();
let string = "<INPUT TYPE=\"HIDDEN\" NAME=\"var1\" VALUE=\"value that i want to be captured\"/><INPUT TYPE=\"HIDDEN\" NAME=\"var2\" VALUE=\"value2\"/><INPUT TYPE=\"SUBMIT\" VALUE=\"value that is captured, but i don't want to be captured\" />";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}