import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:git@github\\.com:)|(?:https://github.com))/?(?P<github_path>(?P<owner>\\w+)/(?P<name>[\\w-]+))(?:\\.git)?$";
final String string = "https://github.com/argoai/labeling.git\n"
+ "git@github.com:argoai/lme-common.git\n"
+ "git@github.com:/argoai/labeling.git\n"
+ "git@github.com:/argoai/labeling";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}