#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=@[A-Za-z]+,\s[A-Za-z]+\[[A-Za-z]+\])\s+|(?<=@[A-Z|a-z]+,)\s+(?![A-Za-z]+\[[A-Za-z]+\])"
Local $sString = "@fsfasfsdf, <<<" & @CRLF & _
"@sdfJKfsd, <<<" & @CRLF & _
"@asdjsdhasLAKJA, <<<" & @CRLF & _
"@A, <<<<" & @CRLF & _
"@noMatchInThisLine,<<<<<" & @CRLF & _
"@sdasdsad, dsajkdlasdfasd[fsadsd] <<<<<<<" & @CRLF & _
"@ noMatchInThisLine, <<<<" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")