using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=@[A-Za-z]+,\s[A-Za-z]+\[[A-Za-z]+\])\s+|(?<=@[A-Z|a-z]+,)\s+(?![A-Za-z]+\[[A-Za-z]+\])";
string input = @"@fsfasfsdf, <<<
@sdfJKfsd, <<<
@asdjsdhasLAKJA, <<<
@A, <<<<
@noMatchInThisLine,<<<<<
@sdasdsad, dsajkdlasdfasd[fsadsd] <<<<<<<
@ noMatchInThisLine, <<<<
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}