package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(ab|cd)e(fg|hi)`)
var str = `abcdefghi`
var substitution = "\1\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}