use strict;
my $str = 'abcdefghi';
my $regex = qr/(ab|cd)e(fg|hi)/p;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";