import Foundation
let pattern = #"(ab|cd)e(fg|hi)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"abcdefghi"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)