$re = '/>\s*\n\s*(\w.*\w)\s*\n\s*</';
$str = '<input>
<program_name>
CS
</program_name>
<course_name>
ART CLASS
</course_name>
<instructor>
John Smith
</instructor>
</input>';
$subst = ">\1<";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;